Issue with TagSetValueString() method

Discussions about image processing and document imaging.
Post Reply
nyalim
Posts: 8
Joined: Mon May 01, 2017 9:01 am

Issue with TagSetValueString() method

Post by nyalim » Thu Oct 19, 2017 11:47 am

Hi all,

I'm having a little bit of problem using TagSetValueString() method to fill some EXIF fields in my TIFF documents.
At first, I tried to fill Tags section under Description but couldn't figure out how to create custom tags in there and gave up;

Image

So if there's no way to programmatically fill that Tags field, then I'd like to fill Comments section right under Tags instead but I don't know which field it is? Is it TagExifUserComment or TagXPComment? Which TagType I should use? There are some differences between EXIF and EXIF2.3 standards. I tried many of these possibilities but that Comments section always ended up empty.

Apart from that, I'd like to also fill Title section under Description, Data taken or Date acquired under Origin section. Would you tell me the TagID's or names for those fields with their corresponding TagTypes? I also need regarding TIFF's to be found by these fields in windows search.

I'm using GdPicture 10 for compatibility reasons by the way. So I don't know which EXIF standard this version points out to.

Helps are appreciated.

Gabriela
Posts: 436
Joined: Wed Nov 22, 2017 9:52 am

Re: Issue with TagSetValueString() method

Post by Gabriela » Fri Jan 18, 2019 9:19 pm

Hello,

here is the documentation page for the TagSetValueString() method:
http://guides.gdpicture.com/content/web ... tring.html
The current version of GdPicture toolkit you can find here: https://www.gdpicture.com/download-gdpicture/
If you will provide the code snippet and the related image, so we can see, if the issue is reproducible with the current release, we can assist you further.
Kind regards,

Gabriela
GdPicture Team

Post Reply

Who is online

Users browsing this forum: No registered users and 25 guests