scanning problem

Discussions about TWAIN scanning in GdPicture.NET using GdPictureImaging.
Post Reply
EricChange
Posts: 2
Joined: Tue Aug 11, 2015 5:41 am

scanning problem

Post by EricChange » Thu Dec 17, 2015 4:15 am

My GdPicture version is 8.5 and my customer use Panasonic KV-S5055C scanner.

It was scanned 5~7 pages and stop about 1 sec then again when they used duplex mode ,but it is normal in simplex. :shock:

They so angry and tell me must to fix it. :twisted: :twisted: :twisted:

I try to fix it has been four days, but problem is still exist. :? :? :?

My code is below:

=============================================

Dim images As List(Of Integer) = New List(Of Integer)

If _oGdPictureImaging.TwainOpenDefaultSource(Me.Handle) Then

 Do

  images.Add(_oGdPictureImaging.TwainAcquireToGdPictureImage(Me.Handle))

 Loop While _oGdPictureImaging.TwainGetState > TwainStatus.TWAIN_SOURCE_ENABLED

 For Each imageId As Integer In images

  saveImage(imageId )

 Next

End If

=============================================

Where's the problem ?

Help me, please !!! :cry: :cry: :cry:

Cedric
Posts: 259
Joined: Sun Sep 02, 2012 7:30 pm

Re: scanning problem

Post by Cedric » Mon Feb 08, 2016 11:07 am

Hello,

The problem is probably that you do not ask the device for duplex mode, my bet would be that default is simplex acquisition.
You should check this is the case using the TwainIsDuplexEnabled method and consider setting it properly with the TwainEnableDuplex method.

I hope this helps.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests