Citrix and TWAIN Question

Discussions about TWAIN scanning in GdPicture.NET using GdPictureImaging.
Post Reply
brian611
Posts: 5
Joined: Mon Apr 23, 2012 6:15 pm

Citrix and TWAIN Question

Post by brian611 » Wed May 14, 2014 7:56 pm

Hello All,

I have encountered a strange situation with a customer site. They have two applications that use the same scan component, this scan component contains GDPicture. The two applications, we will call one 'A' and the other 'B', and both are published applications through Citrix. Following is what happens when the user launches the applications separately:

User Launches application ‘A’, which is published through Citrix:

* It loads the scan component and the scan component does not recognize the scanner attached to the user’s workstation and does not allow the user to scan. Following is the top part of the twain log:

#GdPicture.NET.twain.client Log Start. Version: 705

RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 1
-------------------
standard DSM 32-bit library loaded: C:\Windows\SysWow64\TWAINDSM.DLL
RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 1
-------------------
Entry point of the standard DSM found.
RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 1
-------------------
Start: UnloadSourceManager.
RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 2

User Launches application ‘B’, which is also published through Citrix:

* It loads the scan component and the scan component does recognize the scanner attached to the user’s workstation and does allow the user to scan. Following is the top part of the twain log:

#GdPicture.NET.twain.client Log Start. Version: 705

RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 1
-------------------
standard 32-bit DSM library can not be loaded.
RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 1
-------------------
Start: OpenSourceManager.
RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 1
-------------------
standard DSM 32-bit library loaded: M:\WINDOWS\TWAIN_32.DLL
RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 1
-------------------
Entry point of the standard DSM found.
RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 1
-------------------
End: OpenSourceManager.
RC: TWRC_SUCCESS
CC: TWCC_SUCCESS
State: 3

In talking with the site’s citrix admin he believes both applications are setup the same. Unfortunately I am not a Citrix person, so I am not sure what to check or add to my code to guarantee the scanner will be found. Again, I don’t believe this to be a GDPicture issue, I believe it to be a setup on the Citrix server with application ‘A’.

Thanks for any help in advance

SamiKharma
Posts: 352
Joined: Tue Sep 27, 2011 11:47 am

Re: Citrix and TWAIN Question

Post by SamiKharma » Mon May 19, 2014 10:34 am

Hi,

If you notice the log, both applications are not using the same DSM. I am guessing the first one is faulty.
It is always helpful to debug twain issues with the following protocol:
viewtopic.php?t=1486

Best,
Sami

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests